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Introduction
Leveraging the ultra powerful Artemis Module, the SparkFun MicroMod Artemis Processor is the brain board of
your dreams. With a Cortex-M4F with BLE 5.0 running up to 96MHz and with as low power as 6uA per MHz (less
than 5mW), the M.2 MicroMod connector allows you to plug in a MicroMod Carrier Board with any number of
peripherals. Let's have a look at what this processor board has to offer!

SparkFun MicroMod Artemis Processor
 DEV-16401
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Required Materials

In addition to your MicroMod Artemis Processor Board, you'll need a carrier board to get started. Here we use the
Machine Learning Carrier Board, but there are a number of others you can choose from.

You'll also need a USB-C cable to connect the Carrier to your computer and if you want to add some Qwiic
breakouts to your MicroMod project you'll want at least one Qwiic cable to connect it all together. Below are some
options for both of those cables:

SparkFun MicroMod Machine Learning Carrier
Board
 DEV-16400

SparkFun MicroMod Data Logging Carrier Board
 DEV-16829

SparkFun MicroMod ATP Carrier Board
 DEV-16885

SparkFun Qwiic Cable Kit
 KIT-15081

Reversible USB A to C Cable - 2m
 CAB-15424
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Depending on which Carrier Board you choose, you may need a few extra peripherals to take full advantage of
them. Refer to the Carrier Boards' respective Hookup Guides for specific peripheral recommendations.

Suggested Reading

The SparkFun MicroMod ecosystem is a unique way to allow users to customize their project to their needs. Do
you want to send your weather data via a wireless signal (eg. Bluetooth or WiFi)? There's a MicroMod processor
for that. Looking to instead maximize efficiency and processing powere? You guessed it, there's a MicroMod
processor for that. If you are not familiar with the MicroMod system, take a look here:

MicroMod Ecosystem

We also recommend taking a look through the following tutorials if you are not familiar with the concepts covered
in them:

USB 3.1 Cable A to C - 3 Foot
 CAB-14743

Getting Started with MicroMod
Dive into the world of MicroMod - a compact interface
to connect a microcontroller to various peripherals via
the M.2 Connector!

New!

Designing with MicroMod
This tutorial will walk you through the specs of the
MicroMod processor and carrier board as well as the
basics of incorporating the MicroMod form factor into
your own PCB designs!

New!

https://www.sparkfun.com/micromod
https://www.sparkfun.com/micromod
https://www.sparkfun.com/products/14743
https://learn.sparkfun.com/static/bubbles/
https://www.sparkfun.com/products/14743
https://learn.sparkfun.com/tutorials/getting-started-with-micromod
https://learn.sparkfun.com/tutorials/designing-with-micromod


Hardware Overview
While the Artemis module is pretty self-contained, let's have a look at a few of the unique features of this MicroMod
Processor Board.

Power

Power is supplied by the carrier board, but it should be noted that all pins are 3.3V.

⚡ Warning: All pins are 3.3V. DO NOT expose the pins to 5V.  

The ADC on the Artemis is 0-2V. Exposing an ADC pin to 3.3V will not harm the device but the ADC will
saturate returning 16,383 (14-bit) for voltages greater than 2V.

M.2 Connector

All of our MicroMod Processor boards come equipped with the M.2 MicroMod Connector, which leverages the
M.2 standard and specification to allow you to install your MicroMod Processor board on your choice of carrier
board.

MicroMod Machine Learning Carrier Board
Hookup Guide
Get hacking with this tutorial on our Machine Learning
Carrier Board!

New!

https://en.wikipedia.org/wiki/M.2
https://learn.sparkfun.com/tutorials/micromod-machine-learning-carrier-board-hookup-guide


  

M.2 Connector from the Front M.2 Connector from the Back

Artemis Processor

The SparkFun Artemis Processor provides a Cortex-M4F with BLE 5.0 running up to 96MHz and with as low
power as 6uA per MHz (less than 5mW). This module is powerful enough to run TensorFlow, Machine Learning,
and all sorts of voice recognition software. A deep dive into all of Artemis's delightful features can be found in the
Designing with the SparkFun Artemis tutorial.

Op Amp

Incoming analog voltages over 2V will saturate the Artemis's analog to digital converter. We've integrated an
OpAmp to scale the incoming 0-3.3V voltages down to the 0-2V range that the Artemis can handle.
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RTC

An onboard RTC crystal has been integrated.

Status LED

We've also included a Status LED for all your blinky needs.

https://cdn.sparkfun.com/assets/learn_tutorials/1/1/9/1/16401-SparkFun-MicroMod-Artemis-Processor_OpAmp.jpg
https://cdn.sparkfun.com/assets/learn_tutorials/1/1/9/1/16401-SparkFun-MicroMod-Artemis-Processor_RTC.jpg


Artemis MicroMod Processor Pin Functionality

Note: You may not recognize the COPI/CIPO labels for SPI pins. SparkFun is working to move away from
using MISO/MOSI to describe signals between the controller and the peripheral. Check out this page for
more on our reasoning behind this change.

AUDIO UART GPIO/BUS I C SDIO SPI0 Dedicated

Alternate
Function

Primary Function Bottom Pin    Top    Pin Primary
Function

Alternate
Function

73 G5

71 G6

QSPI3 SPI_CS 70 69 G7

QSPI2 68

QSPI1 66 65 TX1 ADC_D-

QSPI0 SPI_CIPO 64 63 ADC_D+

QSPI_CS SPI_COPI 62 61 SPI_CIPO1

ARTEMIS PROCESSOR BOARD PINOUT TABLE

MICROMOD GENERAL PINOUT TABLE

MICROMOD GENERAL PIN DESCRIPTIONS

2

https://cdn.sparkfun.com/assets/learn_tutorials/1/1/9/1/16401-SparkFun-MicroMod-Artemis-Processor_StatusLED.jpg
https://www.sparkfun.com/spi_signal_names


QSPI_SCK SPI_SCK 60 59 SPI_COPI1

CAM_MCLK 58 57 SPI_SCK1

CAM_MCLK 56 55 SPI_CS1

CAM_PCLK 54 53 SCL1

PDM_DATA 52 51 SDA1

PDM_CLK 50 49 BATT_VIN3

G4 48 47 PWM1

G3 46

G2 44

G1 42

G0 40 39 GND

ADC1 38

ADC0 34

PWM0 32

23 SWDIO

21 SWDCK

19 RX1

D1 18 17 TX1 ADC_D-

I C_Interrupt 16 15 CTS1

SCL 14 13 RTS1

SDA 12 11 BOOT

D0 10 9

7 GND

RESET 6 5 USB_D-

3 USB_D+

3.3V 2 1 GND
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Board Dimensions

The board measures 22mm x 22mm, with 15mm to the top notch and 12mm to the E key. For more information
regarding the processor board physical standards, head on over to the Getting Started with MicroMod tutorial and
check out the Hardware Overview section.

Hardware Hookup
To get started with the Artemis MicroMod Processor Board, you'll need a carrier board. Here we are using the
Machine Learning Carrier Board. Align the top key of the MicroMod Artemis Processor Board to the screw terminal
of the Machine Learning Carrier Board and angle the board into the socket. Insert the board at an angle into the
M.2 connector.

Note: There is no way to insert the processor backward since the key prevents it from mating with the M.2
connector and as an extra safeguard to prevent inserting a processor that matches the key, the mounting
screw is offset so you will not be able to secure an improperly connected processor board.

The Processor Board will stick up at an angle, as seen here:

https://learn.sparkfun.com/tutorials/getting-started-with-micromod#hardware-overview
https://learn.sparkfun.com/tutorials/getting-started-with-micromod#hardware-overview
https://cdn.sparkfun.com/assets/learn_tutorials/1/1/8/9/SparkFun_MicroMod_Processor_Board_Dimensions.jpg
https://www.sparkfun.com/products/16400
https://cdn.sparkfun.com/assets/learn_tutorials/1/1/9/1/MicroMod_Artemis_in_Machine_Learning_Carrier_Board.jpg


Once the board in the socket, gently push the MicroMod Processor Board down and tighten the screw with a
Phillip's head.

Once the board is secure, your assembled MicroMod system should look similar to the image below!

Connecting Everything Up

With your processor inserted and secured it's time to connect your carrier board to your computer using the USB-C
connector on the Carrier. Depending on which carrier you choose and which drivers you already have installed,
you may need to install drivers.

Note: If you've never connected a CH340 device to your computer before, you may need to install drivers for
the USB-to-serial converter. Check out our section on "How to Install CH340 Drivers" for help with the
installation.  

https://cdn.sparkfun.com/assets/learn_tutorials/1/1/8/9/MicroMod_Getting_Started_Guide_Images-01.jpg
https://cdn.sparkfun.com/assets/learn_tutorials/1/1/8/9/MicroMod_Getting_Started_Guide_Images-02.jpg
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Software Setup

Note: This example assumes you are using the latest version of the Arduino IDE on your desktop. If this is
your first time using Arduino, please review our tutorial on installing the Arduino IDE.

Installing the Arduino Core for Apollo3

To get started with the Artemis MicroMod Processor Board, you'll need to install the SparkFun Apollo3 Arduino
Core. Open the Arduino IDE (must be v1.8.13 or later) and navigate to File->Preferences, like so:

Having a hard time seeing? Click the image for a closer look.

In the "Additional Board Manager URL" box, make sure you have the following json file:

https://raw.githubusercontent.com/sparkfun/Arduino_Boards/master/IDE_Board_Manager/package_spark
fun_index.json 

If you have more than one json file, you can click on the button outlined in red and add the json link at the end. It'll
look something like the following:

How to Install CH340 Drivers
AUGUST 6, 2019
How to install CH340 drivers (if you need them) on Windows, Mac OS X, and
Linux.

https://learn.sparkfun.com/tutorials/installing-arduino-ide
https://cdn.sparkfun.com/assets/learn_tutorials/9/1/1/Arduino-Preferences.png
https://learn.sparkfun.com/tutorials/how-to-install-ch340-drivers


Having a hard time seeing? Click the image for a closer look.

Go to Tools -> Board and select the Boards Manager

Having a hard time seeing? Click the image for a closer look.

Search for "Apollo3", and you should find the SparkFun Apollo3 Boards board package. Make sure the Version
1.2.1 is selected and click Install.

Having a hard time seeing? Click the image for a closer look.

Installation may take a few minutes -- included in the install are all necessary source files for the Arduino core and
Apollo3 libraries, plus all of the compiler and software-upload tools you'll need to use the Artemis with Arduino.

Once the board definitions have been installed, you should see the Artemis MicroMod Processor board under your
Tools -> Board -> SparkFun Apollo3 menu.

https://cdn.sparkfun.com/assets/learn_tutorials/1/1/9/1/PreferencesButtonLink.png
https://cdn.sparkfun.com/assets/learn_tutorials/9/1/1/Arduino-BoardsManager.png
https://cdn.sparkfun.com/assets/learn_tutorials/1/1/9/1/BoardsManager-VersionSelection.png


Having a hard time seeing? Click the image for a closer look.

Example 1: Blink

Note: This example assumes you are using the latest version of the Arduino IDE on your desktop. If this is
your first time using Arduino, please review our tutorial on installing the Arduino IDE. If you have not
previously installed an Arduino library, please check out our installation guide.

To get started uploading code and working with your Machine Learning Carrier Board, make sure you have the
Artemis MicroMod board definition selected under your Tools > Board menu (or whatever processor you've
chosen to use).

Having a hard time seeing? Click the image for a closer look.

Then select your serial port under the Tools > Port menu.

Loading Blink

Let's start with something basic - let's blink an LED. Go to File->Examples->01.Basics->Blink.

https://cdn.sparkfun.com/assets/learn_tutorials/1/1/9/1/BoardDropDown.png
https://learn.sparkfun.com/tutorials/installing-arduino-ide
https://learn.sparkfun.com/tutorials/installing-an-arduino-library
https://cdn.sparkfun.com/assets/learn_tutorials/1/3/9/5/BoardDropDown.png
https://cdn.sparkfun.com/assets/learn_tutorials/1/3/9/5/portSelect.png


Having a hard time seeing? Click the image for a closer look.

With everything setup correctly, upload the code! Once the code finishes transferring, you should see the STAT
LED on the Artemis Processor Board begin to blink!

If the blue LED remains off, it's probably still sitting in the bootloader. After uploading a sketch, you may need
to tap the reset button to get your Artemis MicroMod to run the sketch.

Look at all the blinks!

Example 2: PDM
We've built the Arduino core for Artemis from the ground up and a large number of our built-in examples will work
out of the box with the Artemis MicroMod Processor Board. You'll find them under File->Examples->'Examples
for SparkFun Artemis MicroMod'.

Let's run a quick one from the examples here and take advantage of the two built in microphones on the Machine
Learning Carrier Board we're using. Go to File->Examples->PDM->Example1_MicrophoneOutput

Click above image for full menu context

Make sure you have the correct board and port selected, and then upload the code. Once the code finishes
transferring, open the serial monitor and set the baud rate to 115200. You should see something like the
following:

https://cdn.sparkfun.com/assets/learn_tutorials/1/3/9/5/BlinkExamplePulldown.png
https://cdn.sparkfun.com/assets/learn_tutorials/1/3/9/5/MachineLearningBlink.gif
https://cdn.sparkfun.com/assets/learn_tutorials/9/1/1/Artemis-I2C-Examples-FullMenu.jpg
https://learn.sparkfun.com/tutorials/terminal-basics


Having a hard time seeing? Click the image for a closer look.

Notice that if you hoot and holler, the output changes.

Within the 'Examples for SparkFun Artemis Micromod' menu, we've got examples for setting up multiple I C ports
(it's amazingly easy), writing to EEPROM, using SoftwareSerial (all 48 pins can be serial!), using the the onboard
microphone, and using servos (up to 32!). We're adding more all the time so be sure to keep your core up to date.

Further Examples
With the MicroMod system, the possibilities for examples with all the processor/carrier board are endless, and we
just can't cover them all. You'll notice that in this tutorial, we've selected the Machine Learning Carrier Board, but
have focused our examples on the Artemis Processor Board. If you're interested in examples specifically for our
carrier board, head on over to our Machine Learning Carrier Board Hookup Guide.

Troubleshooting

 Need help? 

If your product is not working as you expected or you need technical assistance or information, head on over
to the SparkFun Technical Assistance page for some initial troubleshooting.  

If you don't find what you need there, the SparkFun Forums are a great place to find and ask for help. If this
is your first visit, you'll need to create a Forum Account to search product forums and post questions.  

SparkFun MicroMod Forums

Resources and Going Further
Want more information on the Artemis MicroMod Processor Board? Check out these links!

Schematic (PDF)
Eagle Files (ZIP)
Apollo3 Datasheet
GitHub Hardware Repo

MicroMod Documentation:

Getting Started with MicroMod
Designing with MicroMod
MicroMod Info Page
MicroMod Forums
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Artemis Documentation:

Artemis Integration Guide
Designing with the SparkFun Artemis
Artemis Development with Arduino
Arduino Core
Apollo3 Pin Map

Looking for some project inspiration using your Artemis Processor Board? The tutorials below can help you get
started!

Designing with MicroMod
This tutorial will walk you through the specs of the
MicroMod processor and carrier board as well as the
basics of incorporating the MicroMod form factor into
your own PCB designs!

New!

MicroMod SAMD51 Processor Board Hookup
Guide
This tutorial covers the basic functionality of the
MicroMod SAMD51 and highlights the features of the
ARM Cortex-M4F development board.

New!

MicroMod All The Pins (ATP) Carrier Board
Access All The Pins (ATP) of the MicroMod Processor
Board with the Carrier Board!

New!

MicroMod Data Logging Carrier Board Hookup
Guide
Get started with some customizable MicroMod data
logging with the Data Logging Carrier Board.

New!

https://cdn.sparkfun.com/assets/8/7/5/3/f/Artemis_Integration_Guide.pdf
https://learn.sparkfun.com/tutorials/designing-with-the-sparkfun-artemis
https://learn.sparkfun.com/tutorials/artemis-development-with-arduino
https://github.com/sparkfun/Arduino_Apollo3
https://cdn.sparkfun.com/assets/8/2/3/3/c/Apollo3_Pad_Mapping.pdf
https://learn.sparkfun.com/tutorials/designing-with-micromod
https://learn.sparkfun.com/tutorials/micromod-samd51-processor-board-hookup-guide
https://learn.sparkfun.com/tutorials/micromod-all-the-pins-atp-carrier-board
https://learn.sparkfun.com/tutorials/micromod-data-logging-carrier-board-hookup-guide



